high · 7.7 Patched

Incorrect version tags linked to external repository

CVE-2021-47986 · CVE-2021-47987 · GHSA-593v-wcqx-hq2w · BIT-parse-2021-47986 · BIT-parse-2021-47987 · published 7 Sept 2021

How serious is it

  • Severity: high, CVSS score 7.7 out of 10.
  • No exploit prediction (EPSS) score yet.
  • Not on the CISA list of exploited vulnerabilities.
  • No public exploit in Exploit-DB.

Is your app affected by CVE-2021-47986?

Paste this prompt into Claude Code, Cursor or any AI coding tool: it runs a free Shippable scan of your project and fixes what it finds. Built with Lovable, Bolt or v0? Scan your live app. Or upload your package file.

Who is affected

  • parse-server (npm) >= 4.0.0, < 4.5.2
  • parse-server (npm) >= 4.6.0, < 4.10.0

How to check

  1. Run npm ls parse-server in your project to see the installed version, including copies pulled in by other packages.
  2. Or paste your lockfile into the checker: it lists every package with a known vulnerability, this one included.
  3. Or run npx shippable-dev scan localhost:3000 in your project folder. It reads your lockfile and flags this vulnerability along with every other known one.

How to fix

Copies a prompt for Claude Code, Cursor or Codex: it checks your lockfiles for this and upgrades it.
  1. On >= 4.0.0, < 4.5.2: Upgrade parse-server to 4.5.2 or later, commit the lockfile and redeploy.
  2. On >= 4.6.0, < 4.10.0: Upgrade parse-server to 4.10.0 or later, commit the lockfile and redeploy.
  3. If a vulnerable version was live, check your logs and rotate the secrets that server could read.

The advisory

### Impact A security incident caused a number of incorrect version tags to be pushed to the Parse Server repository. These version tags linked to a personal fork of a contributor who had write access to the repository. The code to which these tags linked has not been reviewed or approved by Parse Platform. Even though no releases were published with these incorrect versions, it was possible to define a Parse Server dependency that pointed to these version tags, for example if you defined this dependency: ```js "parse-server": "git@github.com:parse-community/parse-server.git#4.9.3" ``` We have since deleted the incorrect version tags, but they may still show up in your personal fork on GitHub or locally. We do not know when these tags have been pushed to the Parse Server repository, but we first became aware of this issue on July 21, 2021. We are not aware of any malicious code or concerns related to privacy, security or legality (e.g. proprietary code). However, it has been reported that some functionality does not work as expected and the introduction of security vulnerabilities cannot be ruled out. You may be also affected if you used the Bitnami image for Parse Server. Bitnami picked up the incorrect version tag `4.9.3` and published a new Bitnami image for Parse Server. **If you are using any of the affected versions, we urgently recommend to upgrade to version `4.10.0`.** These are the incorrect tags: ``` 4.0.0-beta1 4.0.0-beta2 4.0.0-beta3 4.0.0-beta4 4.0.0-beta5 4.0.0-beta6 4.0.10 4.0.11 4.0.12 4.0.13 4.0.14 4.0.3 4.0.4 4.0.6 4.0.7 4.0.8 4.0.9 4.6.0 4.6.0-beta 4.7.0 4.8.0 4.8.1 4.8.2 4.8.3 4.8.4 4.8.5 4.9.0 4.9.1 4.9.2 4.9.3 ``` ### Patches Upgrade to version `4.10.0`. ### Workarounds Downgrade to version `4.5.2`. ### References n/a

Check your whole app

Dependencies are only half of it. Free and read-only: before you push, run npx shippable-dev scan localhost:3000 in your project folder, no account needed. For your live app, you prove it's yours with a one-line tag first.

References

Merged from GitHub Advisory Database, OSV. Last updated 3 Nov 2026. All vulnerabilities · RSS · JSON