internetarchive Vulnerable to Directory Traversal in File.download()
CVE-2025-58438 · GHSA-wx3r-v6h7-frjp · PYSEC-2026-357 · published 5 Sept 2025
How serious is it
- Severity: critical, CVSS score 9.4 out of 10.
- No exploit prediction (EPSS) score yet.
- Not on the CISA list of exploited vulnerabilities.
- No public exploit in Exploit-DB.
Is your app affected by CVE-2025-58438?
Paste this prompt into Claude Code, Cursor or any AI coding tool: it runs a free Shippable scan of your project and fixes what it finds. Built with Lovable, Bolt or v0? Scan your live app. Or upload your package file.
Who is affected
internetarchive(PyPI) <= 5.5.0
How to check
- Run
pip show internetarchivein your project to see the installed version, including copies pulled in by other packages. - Or paste your lockfile into the checker: it lists every package with a known vulnerability, this one included.
- Or run
npx shippable-dev scan localhost:3000in your project folder. It reads your lockfile and flags this vulnerability along with every other known one.
How to fix
Copies a prompt for Claude Code, Cursor or Codex: it checks your lockfiles for this and upgrades it.
- Upgrade
internetarchiveto 5.5.1 or later, commit the lockfile and redeploy. - If a vulnerable version was live, check your logs and rotate the secrets that server could read.
The advisory
### Impact
**What kind of vulnerability is it?**
This is a **Critical** severity directory traversal (path traversal) vulnerability in the `File.download()` method of the `internetarchive` library.
**Who is impacted?**
All users of the `internetarchive` library versions `< 5.5.1` are impacted. The vulnerability is particularly critical for users on **Windows systems**, but all operating systems are affected.
**Description of the vulnerability:**
The vulnerability existed because the `file.download()` method did not properly sanitize user-supplied filenames or validate the final download path. A maliciously crafted filename could contain path traversal sequences (e.g., `../../../../windows/system32/file.txt`) or illegal characters that, when processed, would cause the file to be written outside of the intended target directory.
**Potential Impact:**
An attacker could potentially overwrite critical system files or application configuration files, leading to a denial of service, privilege escalation, or remote code execution, depending on the context in which the library is used.
### Patches
**Has the problem been patched?**
Yes, the problem has been patched.
**What versions should users upgrade to?**
Users must upgrade to version **5.5.1** or later.
### Workarounds
Is there a way for users to fix or remediate the vulnerability without upgrading?
There is no direct workaround that does not involve upgrading the library. The vulnerability is in the core logic of the file download process.
The only alternative for users who absolutely cannot upgrade is to implement their own custom download function that:
1. Manually sanitizes all filenames using a robust method.
2. Validates that the resolved absolute path of the download target is within the intended directory before writing any files.
However, this essentially re-implements the fix and is not recommended. Upgrading to the patched version is the only safe and supported solution.
### References
- [Release Notes for v5.5.1](https://github.com/jjjake/internetarchive/releases/tag/v5.5.1)
- [Commit with the fix](https://github.com/jjjake/internetarchive/commit/cba2d459e10a9489fb35caeba0b03e80f5f5d7c2)
- **CVE Identifier:** CVE-2025-58438
Check your whole app
Dependencies are only half of it. Free and read-only: before you push, run npx shippable-dev scan localhost:3000 in your project folder, no account needed. For your live app, you prove it's yours with a one-line tag first.
References
- github.com/jjjake/internetarchive/security/advisories/GHSA-wx3r-v6h7-frjp
- github.com/jjjake/internetarchive/commit/cba2d459e10a9489fb35caeba0b03e80f5f5d7c2
- github.com/jjjake/internetarchive/releases/tag/v5.5.1
- nvd.nist.gov/vuln/detail/CVE-2025-58438
- lists.debian.org/debian-lts-announce/2025/09/msg00030.html
- github.com/pypa/advisory-database/tree/main/vulns/internetarchive/PYSEC-2026-357.yaml
- pypi.org/project/internetarchive
- github.com/advisories/GHSA-wx3r-v6h7-frjp
- github.com/jjjake/internetarchive
Merged from GitHub Advisory Database, OSV. Last updated 28 Oct 2026. All vulnerabilities · RSS · JSON