Payload external upload trust validation issue
CVE-2026-105861 · GHSA-pj5h-5q6c-3pfx · published 7 Oct 2026
How serious is it
- Severity: high, CVSS score 7.2 out of 10.
- No exploit prediction (EPSS) score yet.
- Not on the CISA list of exploited vulnerabilities.
- No public exploit in Exploit-DB.
Is your app affected by CVE-2026-105861?
Paste this prompt into Claude Code, Cursor or any AI coding tool: it runs a free Shippable scan of your project and fixes what it finds. Built with Lovable, Bolt or v0? Scan your live app. Or upload your package file.
Who is affected
payload(npm) >= 3.0.0, < 3.90.0payload(npm) >= 4.0.0-canary.0, < 4.0.0-canary.34
How to check
- Run
npm ls payloadin your project to see the installed version, including copies pulled in by other packages. - Or paste your lockfile into the checker: it lists every package with a known vulnerability, this one included.
- Or run
npx shippable-dev scan localhost:3000in your project folder. It reads your lockfile and flags this vulnerability along with every other known one.
How to fix
Copies a prompt for Claude Code, Cursor or Codex: it checks your lockfiles for this and upgrades it.
- On >= 3.0.0, < 3.90.0: Upgrade
payloadto 3.90.0 or later, commit the lockfile and redeploy. - On >= 4.0.0-canary.0, < 4.0.0-canary.34: Upgrade
payloadto 4.0.0-canary.34 or later, commit the lockfile and redeploy. - If a vulnerable version was live, check your logs and rotate the secrets that server could read.
The advisory
## Impact
Under certain external upload configurations, Payload could send authentication data to a destination that was not verified as trusted. If the affected request contained a valid session, this could expose that session to an unintended recipient.
**You are affected if:**
- You have enabled external URL-based upload retrieval, where authenticated requests can trigger it.
## Patches
Payload now validates the destination before forwarding authentication data and reapplies that validation when a request changes destination.
Users should upgrade Payload packages to `>= 3.90.0` or `>= 4.0.0-canary.34`.
## Workarounds
It is recommended to update all Payload packages to `>= 3.90.0` or `>= 4.0.0-canary.34`.
If you cannot, a valid workaround exists:
- Disable external URL-based upload retrieval where practical.
- If you cannot disable it, configure the upload header filter to remove authentication data from outbound file requests.
- Restrict access to the affected upload functionality.
Check your whole app
Dependencies are only half of it. Free and read-only: before you push, run npx shippable-dev scan localhost:3000 in your project folder, no account needed. For your live app, you prove it's yours with a one-line tag first.
References
- github.com/payloadcms/payload/security/advisories/GHSA-pj5h-5q6c-3pfx
- nvd.nist.gov/vuln/detail/CVE-2026-105861
- github.com/payloadcms/payload/commit/ba5cf6ae20d27a2c15106cb37466419031f86e6d
- github.com/payloadcms/payload/releases/tag/v3.90.0
- github.com/advisories/GHSA-pj5h-5q6c-3pfx
Merged from GitHub Advisory Database. Last updated 23 Oct 2026. All vulnerabilities · RSS · JSON