high · 7.7 Patched

LiteLLM: Privilege Escalation to Proxy Admin via Cross-Domain Reuse of the Salt Key

CVE-2026-114612 · GHSA-7hp6-4w63-5g45 · published 27 Oct 2026

How serious is it

  • Severity: high, CVSS score 7.7 out of 10.
  • No exploit prediction (EPSS) score yet.
  • Not on the CISA list of exploited vulnerabilities.
  • No public exploit in Exploit-DB.

Is your app affected by CVE-2026-114612?

Paste this prompt into Claude Code, Cursor or any AI coding tool: it runs a free Shippable scan of your project and fixes what it finds. Built with Lovable, Bolt or v0? Scan your live app. Or upload your package file.

Who is affected

  • litellm (PyPI) >= 1.91.0, < 1.100.4
  • litellm (PyPI) >= 1.101.0, < 1.101.3
  • litellm (PyPI) >= 1.102.0, < 1.102.2
  • litellm (PyPI) >= 1.103.0, < 1.103.1
  • litellm (PyPI) >= 1.104.0rc1, < 1.104.0rc2

How to check

  1. Run pip show litellm in your project to see the installed version, including copies pulled in by other packages.
  2. Or paste your lockfile into the checker: it lists every package with a known vulnerability, this one included.
  3. Or run npx shippable-dev scan localhost:3000 in your project folder. It reads your lockfile and flags this vulnerability along with every other known one.

How to fix

Copies a prompt for Claude Code, Cursor or Codex: it checks your lockfiles for this and upgrades it.
  1. On >= 1.91.0, < 1.100.4: Upgrade litellm to 1.100.4 or later, commit the lockfile and redeploy.
  2. On >= 1.101.0, < 1.101.3: Upgrade litellm to 1.101.3 or later, commit the lockfile and redeploy.
  3. On >= 1.102.0, < 1.102.2: Upgrade litellm to 1.102.2 or later, commit the lockfile and redeploy.
  4. On >= 1.103.0, < 1.103.1: Upgrade litellm to 1.103.1 or later, commit the lockfile and redeploy.
  5. On >= 1.104.0rc1, < 1.104.0rc2: Upgrade litellm to 1.104.0rc2 or later, commit the lockfile and redeploy.
  6. If a vulnerable version was live, check your logs and rotate the secrets that server could read.

The advisory

### Summary An authenticated user with `internal_user` privileges can escalate to `proxy_admin` and achieve remote code execution. The proxy uses one encryption key for two purposes: sealing secrets at rest and minting session tokens. An attacker exploits this by requesting a new API key with a crafted metadata field containing a forged admin credential as the "secret" value. The proxy encrypts and returns this payload. When this value is then presented as a bearer token, the proxy decrypts it, trusts the forged admin identity, and grants full administrative access, including the ability to execute arbitrary commands via the MCP stdio endpoint. ### Affected versions Versions later than 1.91.0 are exploitable in the default configuration. Versions 1.87.0 through 1.90.x are exploitable only if `EXPERIMENTAL_UI_LOGIN=true` was explicitly set. ### Mitigation Upgrade to a patched version as soon as possible. If you cannot upgrade immediately, set `EXPERIMENTAL_UI_LOGIN=false`. This disables the vulnerable authentication path but also breaks CLI SSO and Claude Code gateway login. ### Impact An internal user can escalate to proxy admin and execute arbitrary commands on the host. **Discovery Credit:** Hoa X. Nguyen (OPSWAT Unit 515)

Check your whole app

Dependencies are only half of it. Free and read-only: before you push, run npx shippable-dev scan localhost:3000 in your project folder, no account needed. For your live app, you prove it's yours with a one-line tag first.

References

Merged from GitHub Advisory Database, OSV. Last updated 28 Oct 2026. All vulnerabilities · RSS · JSON