TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` serialization
CVE-2026-116675 · GHSA-mf2p-h6hf-fcwm · published 27 Oct 2026
How serious is it
- Severity: high, CVSS score 8.5 out of 10.
- No exploit prediction (EPSS) score yet.
- Not on the CISA list of exploited vulnerabilities.
- No public exploit in Exploit-DB.
Is your app affected by CVE-2026-116675?
Paste this prompt into Claude Code, Cursor or any AI coding tool: it runs a free Shippable scan of your project and fixes what it finds. Built with Lovable, Bolt or v0? Scan your live app. Or upload your package file.
Who is affected
tinymce(npm) >= 8.5.1, < 8.9.3TinyMCE(NuGet) >= 8.5.1, < 8.9.3tinymce/tinymce(Packagist) >= 8.5.1, < 8.9.3tinymce(npm) = 7.9.3TinyMCE(NuGet) = 7.9.3tinymce/tinymce(Packagist) = 7.9.3
How to check
- Run
npm ls tinymcein your project to see the installed version, including copies pulled in by other packages. - Look for
TinyMCEin your lockfile and compare its version with the range above. - Run
composer show tinymce/tinymcein your project to see the installed version, including copies pulled in by other packages. - Or paste your lockfile into the checker: it lists every package with a known vulnerability, this one included.
- Or run
npx shippable-dev scan localhost:3000in your project folder. It reads your lockfile and flags this vulnerability along with every other known one.
How to fix
Copies a prompt for Claude Code, Cursor or Codex: it checks your lockfiles for this and upgrades it.
- On >= 8.5.1, < 8.9.3: Upgrade
tinymceto 8.9.3 or later, commit the lockfile and redeploy. - On >= 8.5.1, < 8.9.3: Upgrade
TinyMCEto 8.9.3 or later, commit the lockfile and redeploy. - On >= 8.5.1, < 8.9.3: Upgrade
tinymce/tinymceto 8.9.3 or later, commit the lockfile and redeploy. - On = 7.9.3: Upgrade
tinymceto 7.9.4 or later, commit the lockfile and redeploy. - On = 7.9.3: Upgrade
TinyMCEto 7.9.4 or later, commit the lockfile and redeploy. - On = 7.9.3: Upgrade
tinymce/tinymceto 7.9.4 or later, commit the lockfile and redeploy. - If a vulnerable version was live, check your logs and rotate the secrets that server could read.
The advisory
### Impact
Stored XSS vulnerability in the media plugin. Attackers can inject malicious scripts via elements crafted through the data-mce-object attribute, which are created and executed before sanitization. Impacts users of TinyMCE with the media plugin enabled.
### Patches
This vulnerability has been patched in TinyMCE 8.9.3 and TinyMCE 7.9.4 by ensuring that, when using the media plugin, any content created through the data-mce-object attribute is properly sanitized first.
### Workarounds
No official workaround available.
### Fix
To avoid this vulnerability:
Upgrade to TinyMCE 8.9.3 or higher.
Upgrade to TinyMCE 7.9.4 or higher.
### Acknowledgements
Tiny thanks [Fariskhi Vidyan](https://github.com/farisv) and David Vieira Kurz (HiSolutions AG) for their help identifying this vulnerability.
Check your whole app
Dependencies are only half of it. Free and read-only: before you push, run npx shippable-dev scan localhost:3000 in your project folder, no account needed. For your live app, you prove it's yours with a one-line tag first.
References
- github.com/tinymce/tinymce/security/advisories/GHSA-mf2p-h6hf-fcwm
- nvd.nist.gov/vuln/detail/CVE-2026-116675
- github.com/tinymce/tinymce/commit/bd1ab5ef024c648c3f9c0b409e54a6c227c7d8a2
- github.com/tinymce/tinymce/releases/tag/8.9.3
- www.tiny.cloud/docs/tinymce/7/7.9.4-release-notes/#overview
- www.tiny.cloud/docs/tinymce/latest/8.9.3-release-notes/#overview
- github.com/advisories/GHSA-mf2p-h6hf-fcwm
- github.com/tinymce/tinymce
Merged from GitHub Advisory Database, OSV. Last updated 28 Oct 2026. All vulnerabilities · RSS · JSON