high · 8.6 Patched

Highcharts Grid parses pagination language options as HTML

CVE-2026-118254 · GHSA-r5wg-q8fc-p6w2 · published 28 Oct 2026

How serious is it

  • Severity: high, CVSS score 8.6 out of 10.
  • No exploit prediction (EPSS) score yet.
  • Not on the CISA list of exploited vulnerabilities.
  • No public exploit in Exploit-DB.

Is your app affected by CVE-2026-118254?

Paste this prompt into Claude Code, Cursor or any AI coding tool: it runs a free Shippable scan of your project and fixes what it finds. Built with Lovable, Bolt or v0? Scan your live app. Or upload your package file.

Who is affected

  • @highcharts/grid-lite (npm) >= 2.0.0, <= 3.1.0
  • @highcharts/grid-pro (npm) >= 2.0.0, <= 3.1.0

How to check

  1. Run npm ls @highcharts/grid-lite in your project to see the installed version, including copies pulled in by other packages.
  2. Run npm ls @highcharts/grid-pro in your project to see the installed version, including copies pulled in by other packages.
  3. Or paste your lockfile into the checker: it lists every package with a known vulnerability, this one included.
  4. Or run npx shippable-dev scan localhost:3000 in your project folder. It reads your lockfile and flags this vulnerability along with every other known one.

How to fix

Copies a prompt for Claude Code, Cursor or Codex: it checks your lockfiles for this and upgrades it.
  1. On >= 2.0.0, <= 3.1.0: Upgrade @highcharts/grid-lite to 3.2.0 or later, commit the lockfile and redeploy.
  2. On >= 2.0.0, <= 3.1.0: Upgrade @highcharts/grid-pro to 3.2.0 or later, commit the lockfile and redeploy.
  3. If a vulnerable version was live, check your logs and rotate the secrets that server could read.

The advisory

### Impact The pagination language strings are written into the DOM as markup rather than as text. An attacker who controls those language options can supply elements carrying event handlers, and those handlers execute in the origin of the page hosting the Grid when the pagination controls render. Exploitation requires that untrusted data reach the Grid language configuration and that pagination be enabled on the Grid. ### Workarounds Run this once after loading the Grid, before creating any grid: ```javascript { const Pagination = Grid.Pagination; const escapeLang = (pagination) => { const lang = pagination.lang; if (!lang) { return; } for (const key of ['pageInfo', 'pageSizeLabel']) { if (typeof lang[key] === 'string') { lang[key] = lang[key].replace(/</g, '&lt;'); } } }; for (const name of ['updatePageInfo', 'renderPageSizeSelector']) { const original = Pagination.prototype[name]; Pagination.prototype[name] = function (...args) { escapeLang(this); return original.apply(this, args); }; } } ``` ### Obtaining the patched version The patched releases are available from all the usual distribution channels. With npm, upgrade the affected package to the patched version listed above, for example `npm install @highcharts/grid-lite@3.2.0`. If you load Highcharts Grid from a CDN, use a versioned URL, for example `https://cdn.jsdelivr.net/npm/@highcharts/grid-lite@3.2.0/grid-lite.js`. For more on each installation method, see the [installation guide](https://www.highcharts.com/docs/grid/installation).

Check your whole app

Dependencies are only half of it. Free and read-only: before you push, run npx shippable-dev scan localhost:3000 in your project folder, no account needed. For your live app, you prove it's yours with a one-line tag first.

References

Merged from GitHub Advisory Database, OSV. Last updated 29 Oct 2026. All vulnerabilities · RSS · JSON