critical · 9.8 Patched

Apache Tomcat - HTTP/2 no-authority bypass of strict SNI validation

CVE-2026-65637 · GHSA-f525-44xv-f2qj · BIT-tomcat-2026-65637 · published 26 Aug 2026

How serious is it

  • Severity: critical, CVSS score 9.8 out of 10.
  • No exploit prediction (EPSS) score yet.
  • Not on the CISA list of exploited vulnerabilities.
  • No public exploit in Exploit-DB.

Is your app affected by CVE-2026-65637?

Paste this prompt into Claude Code, Cursor or any AI coding tool: it runs a free Shippable scan of your project and fixes what it finds. Built with Lovable, Bolt or v0? Scan your live app. Or upload your package file.

Who is affected

  • org.apache.tomcat:tomcat-coyote (Maven) >= 11.0.20, < 11.0.25
  • org.apache.tomcat:tomcat-coyote (Maven) >= 10.1.53, <= 10.1.57
  • org.apache.tomcat:tomcat-coyote (Maven) >= 9.0.115, < 9.0.121
  • org.apache.tomcat.embed:tomcat-embed-core (Maven) >= 11.0.20, < 11.0.25
  • org.apache.tomcat.embed:tomcat-embed-core (Maven) >= 10.1.53, <= 10.1.57
  • org.apache.tomcat.embed:tomcat-embed-core (Maven) >= 9.0.115, < 9.0.121

How to check

  1. Look for org.apache.tomcat:tomcat-coyote in your lockfile and compare its version with the range above.
  2. Look for org.apache.tomcat.embed:tomcat-embed-core in your lockfile and compare its version with the range above.
  3. Or paste your lockfile into the checker: it lists every package with a known vulnerability, this one included.

How to fix

Copies a prompt for Claude Code, Cursor or Codex: it checks your lockfiles for this and upgrades it.
  1. On >= 11.0.20, < 11.0.25: Upgrade org.apache.tomcat:tomcat-coyote to 11.0.25 or later, commit the lockfile and redeploy.
  2. On >= 10.1.53, <= 10.1.57: Upgrade org.apache.tomcat:tomcat-coyote to 10.1.59 or later, commit the lockfile and redeploy.
  3. On >= 9.0.115, < 9.0.121: Upgrade org.apache.tomcat:tomcat-coyote to 9.0.121 or later, commit the lockfile and redeploy.
  4. On >= 11.0.20, < 11.0.25: Upgrade org.apache.tomcat.embed:tomcat-embed-core to 11.0.25 or later, commit the lockfile and redeploy.
  5. On >= 10.1.53, <= 10.1.57: Upgrade org.apache.tomcat.embed:tomcat-embed-core to 10.1.59 or later, commit the lockfile and redeploy.
  6. On >= 9.0.115, < 9.0.121: Upgrade org.apache.tomcat.embed:tomcat-embed-core to 9.0.121 or later, commit the lockfile and redeploy.
  7. If a vulnerable version was live, check your logs and rotate the secrets that server could read.

The advisory

Improper Input Validation vulnerability in Apache Tomcat due to incomplete fix for CVE-2026-32990. This issue affects Apache Tomcat: from 11.0.20 through 11.0.24, from 10.1.53 through 10.1.57, from 9.0.115 through 9.0.120. Users are recommended to upgrade to version 11.0.25, 10.1.59 or 9.0.121, which fix the issue.

Check your whole app

Dependencies are only half of it. Free and read-only: before you push, run npx shippable-dev scan localhost:3000 in your project folder, no account needed. For your live app, you prove it's yours with a one-line tag first.

References

Merged from GitHub Advisory Database, OSV. Last updated 28 Oct 2026. All vulnerabilities · RSS · JSON