high · 7.3

CodeWhale versions >= 0.3.10 and < 0.8.64 (published as deepseek-tui >= 0.3.10 and < 0.8.41 on npm and 0.3.10 through 0.8.41 on crates.io…

CVE-2026-75857 · GHSA-g29h-pfmp-qp9r · EUVD-2026-60964 · published 18 Aug 2026

How serious is it

  • Severity: high, CVSS score 7.3 out of 10.
  • No exploit prediction (EPSS) score yet.
  • Not on the CISA list of exploited vulnerabilities.
  • No public exploit in Exploit-DB.

Is your app affected by CVE-2026-75857?

Paste this prompt into Claude Code, Cursor or any AI coding tool: it runs a free Shippable scan of your project and fixes what it finds. Built with Lovable, Bolt or v0? Scan your live app. Or upload your package file.

Who is affected

  • Hmbown CodeWhale: 0.8.41 <0.8.64
  • Hmbown CodeWhale: 0.3.10 <0.8.41
  • Hmbown CodeWhale: 0.3.10 ≤0.8.41

How to check

  1. Find out whether you run the affected product and which version, then compare it with the versions above.

How to fix

Copies a prompt for Claude Code, Cursor or Codex that asks it to check whether you run this product.
  1. Apply the vendor's update or mitigation from the references below. If there is none yet, limit exposure of the affected service until there is.
  2. If a vulnerable version was live, check your logs and rotate the secrets that server could read.

The advisory

CodeWhale versions >= 0.3.10 and < 0.8.64 (published as deepseek-tui >= 0.3.10 and < 0.8.41 on npm and 0.3.10 through 0.8.41 on crates.io, and as codewhale / codewhale-tui >= 0.8.41 and < 0.8.64) contain a vulnerability in the exec_shell_interact (alias exec_interact) tool, whose approval_requirement returns ApprovalRequirement::Auto. This overrides the default Required approval for code-executing tools, so LLM-controlled stdin is written into an already-approved long-running interactive shell (e.g., a python3 -i REPL, mysql, ssh, or sudo -i session) without any approval prompt. An attacker who can inject instructions via untrusted content the agent ingests (a fetched page, MCP result, or repo file) can cause commands to run at the privilege level of that approved process. Fixed in codewhale / codewhale-tui 0.8.64; the deprecated deepseek-tui crate has no fixed release.

Check your whole app

Dependencies are only half of it. Free and read-only: before you push, run npx shippable-dev scan localhost:3000 in your project folder, no account needed. For your live app, you prove it's yours with a one-line tag first.

References

Merged from ENISA EUVD. Last updated 30 Oct 2026. All vulnerabilities · RSS · JSON