undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation
CVE-2026-87018 · GHSA-qrxm-fqhp-jwvm · published 27 Oct 2026
How serious is it
- Severity: high, CVSS score 7.5 out of 10.
- No exploit prediction (EPSS) score yet.
- Not on the CISA list of exploited vulnerabilities.
- No public exploit in Exploit-DB.
Is your app affected by CVE-2026-87018?
Paste this prompt into Claude Code, Cursor or any AI coding tool: it runs a free Shippable scan of your project and fixes what it finds. Built with Lovable, Bolt or v0? Scan your live app. Or upload your package file.
Who is affected
undici(npm) >= 4.2.1, < 6.29.1undici(npm) >= 7.0.0, < 7.30.1undici(npm) >= 8.0.0, < 8.12.2
How to check
- Run
npm ls undiciin your project to see the installed version, including copies pulled in by other packages. - Or paste your lockfile into the checker: it lists every package with a known vulnerability, this one included.
- Or run
npx shippable-dev scan localhost:3000in your project folder. It reads your lockfile and flags this vulnerability along with every other known one.
How to fix
Copies a prompt for Claude Code, Cursor or Codex: it checks your lockfiles for this and upgrades it.
- On >= 4.2.1, < 6.29.1: Upgrade
undicito 6.29.1 or later, commit the lockfile and redeploy. - On >= 7.0.0, < 7.30.1: Upgrade
undicito 7.30.1 or later, commit the lockfile and redeploy. - On >= 8.0.0, < 8.12.2: Upgrade
undicito 8.12.2 or later, commit the lockfile and redeploy. - If a vulnerable version was live, check your logs and rotate the secrets that server could read.
The advisory
## Impact
undici crashes the client process when a TLS 1.2 server renegotiates after the connection is established and presents a different, CA-trusted certificate whose hostname does not match the requested host. Node.js re-runs hostname verification on the renegotiated handshake and destroys the socket with `ERR_TLS_CERT_ALTNAME_INVALID`. undici's established socket error handler asserted that this error code could never occur, so the peer-controlled error became an uncaught `AssertionError` that terminates the Node.js process. Both the HTTP/1.1 and HTTP/2 paths are affected.
A malicious or compromised HTTPS endpoint reached through undici or the global `fetch()` can crash the client with a single server-initiated renegotiation, taking down all in-flight requests and background work in the process. Only TLS 1.2 is affected, because TLS 1.3 does not support renegotiation. Exploitation does not require a CA compromise: the attacker controls the endpoint and can present two ordinary valid certificates, the first matching the requested URL and the second intentionally not matching it.
## Patches
Upgrade to undici 6.29.1, 7.30.1, or 8.12.2.
## Workarounds
Restrict outbound connections to TLS 1.3, for example by setting `connect: { minVersion: 'TLSv1.3', maxVersion: 'TLSv1.3' }` on the client or agent, so that renegotiation cannot occur, when the target endpoints support TLS 1.3.
Check your whole app
Dependencies are only half of it. Free and read-only: before you push, run npx shippable-dev scan localhost:3000 in your project folder, no account needed. For your live app, you prove it's yours with a one-line tag first.
References
- github.com/nodejs/undici/security/advisories/GHSA-qrxm-fqhp-jwvm
- nvd.nist.gov/vuln/detail/CVE-2026-87018
- github.com/nodejs/undici/commit/12cfd96c3f430897656e3edc1c5e02be8c1cd309
- github.com/nodejs/undici/commit/b40fbfc0651703cf9fa9f6ced68b679f28d8bb28
- github.com/nodejs/undici/commit/e257e9f8fb42eedd50727b9cf65e548c8925e4a8
- cna.openjsf.org/security-advisories.html
- github.com/nodejs/undici/releases/tag/v6.29.1
- github.com/nodejs/undici/releases/tag/v7.30.1
- github.com/nodejs/undici/releases/tag/v8.12.2
- github.com/advisories/GHSA-qrxm-fqhp-jwvm
- github.com/nodejs/undici
Merged from GitHub Advisory Database, OSV. Last updated 28 Oct 2026. All vulnerabilities · RSS · JSON